Contents

hide
<<previous   next>>

Bug 1017 : Cut with non valid range

Status: Solved

geopsy

General information

--FATAL ERROR-

ASSERT: "count()>1" in file ../../dest/include/QGpCoreTools/Curve.h, line 151

2010-05-05 17:02:43.293

main,layerPainter1,layerPainter2

Current thread:

---- thread main
int QGpCoreTools::Curve::indexAfter(double) const [with pointType = QGpCoreWave::FactoryPoint]:150
void QGpCoreTools::Curve::cut(double, double, QGpCoreTools::SamplingOptions) [with pointType = QGpCoreWave::FactoryPoint]:368
virtual void QGpGuiWave::ModalProxy::cut(int, double, double, QGpCoreTools::SamplingOptions):117
void SciFigs::CurveBrowser::cut():572
---- thread layerPainter1
virtual void SciFigs::LayerPainterThread::run():59
---- thread layerPainter2
virtual void SciFigs::LayerPainterThread::run():59

---- thread main
---- thread layerPainter1
---- thread layerPainter2

Developer comments (common to all duplicates if any)

Can be reproduced under Linux: in any curve browser, cut a curve from 2 to 1 (not 1 to 2). Checked "resample": no problem, range is correctly reversed.

Systems and versions

Windows Vista
  Qt                  4.5.3
  QGpCoreTools        1.18.0-snapshot-20100504 from geopsypack-2.1.0-snapshot-20100504	(built on 201005041015)
  GeopsyCore          3.3.0-snapshot-20100504 from geopsypack-2.1.0-snapshot-20100504	(built on 201005041015)
  QGpGuiTools         1.10.0-snapshot-20100504 from geopsypack-2.1.0-snapshot-20100504	(built on 201005041015)
  SciFigs             2.3.0-snapshot-20100504 from geopsypack-2.1.0-snapshot-20100504	(built on 201005041015)
  GeopsyGui           2.8.0-snapshot-20100504 from geopsypack-2.1.0-snapshot-20100504	(built on 201005041015)
  GeopsySLink         1.0.0-snapshot-20100504 from geopsypack-2.1.0-snapshot-20100504	(built on 201005041015)
  GeopsySLinkGui      1.0.0-snapshot-20100504 from geopsypack-2.1.0-snapshot-20100504	(built on 201005041015)
  geopsy              2.7.0-snapshot-20100504 from geopsypack-2.1.0-snapshot-20100504	(built on 201005041015)
  QGpCoreWave         0.8.0-snapshot-20100504 from geopsypack-2.1.0-snapshot-20100504	(built on 201005041015)
  ArrayCore           1.2.0-snapshot-20100504 from geopsypack-2.1.0-snapshot-20100504	(built on 201005041015)
  DinverCore          0.9.0-snapshot-20100504 from geopsypack-2.1.0-snapshot-20100504	(built on 201005041015)
  QGpCompatibility    0.3.0-snapshot-20100504 from geopsypack-2.1.0-snapshot-20100504	(built on 201005041015)
  DinverDCCore        1.5.0-snapshot-20100504 from geopsypack-2.1.0-snapshot-20100504	(built on 201005041015)
  QGpGuiWave          0.6.0-snapshot-20100504 from geopsypack-2.1.0-snapshot-20100504	(built on 201005041015)
  geopsyarray         2.2.0-snapshot-20100504 from geopsypack-2.1.0-snapshot-20100504	(built on 201005041015)
  MonoStation         1.5.0-snapshot-20100504 from geopsypack-2.1.0-snapshot-20100504	(built on 201005041015)
  geopsyhv            2.6.0-snapshot-20100504 from geopsypack-2.1.0-snapshot-20100504	(built on 201005041015)
  structureratios     0.5.0-snapshot-20100504 from geopsypack-2.1.0-snapshot-20100504	(built on 201005041015)

User comments

User reports

14132010-05-05 17:02:39