Contents

hide
<<previous   next>>

Bug 1665 :

Status: Obsolete

geopsy

General information

--FATAL ERROR-

Segmentation fault Signal

2011-05-02 16:15:08.924

main,layerPainter1,layerPainter2,layerPainter3,layerPainter4,parallelLoop,parallelLoop,parallelLoop,parallelLoop

Current thread: parallelLoop

QGpCoreTools::CoreApplicationPrivate::backTrace()
QGpCoreTools::CoreApplicationPrivate::bugInfo(QGpCoreTools::Message::Severity, QString const&)
QGpCoreTools::CoreApplicationPrivate::reportBugNow(QGpCoreTools::Message::Severity, char const*)
QGpCoreTools::CoreApplicationPrivate::osSignal(int)
/lib64/libc.so.6
QHashData::nextNode(QHashData::Node*)
QGpCoreTools::CacheItem::nextPredictedTime() const
QGpCoreTools::AllocatedCacheItem::bestToFree()
QGpCoreTools::Cache::free(double)
QGpCoreTools::Cache::makeAvailable(QGpCoreTools::CacheItem const*)
GeopsyCore::SignalTemplate::lockSamples()
GeopsyCore::DoubleSignal::setValue(double)
GeopsyCore::StationProcessSignals::copyOriginalSignal(int, GeopsyCore::TimeRange const&)
ArrayCore::FKStationSignals::setProcessed(GeopsyCore::TimeRange const&, GeopsyCore::AbstractParameters*)
ArrayCore::ArrayProcess::lockTimeWindow(GeopsyCore::TimeRange const*)
FKLoopTask::run(int)
QGpCoreTools::LoopTask::run()
/usr/local/Trolltech/Qt-4.7.1/lib/libQtCore.so.4
/lib64/libpthread.so.0


---- thread main
---- thread layerPainter1
---- thread layerPainter2
---- thread layerPainter3
---- thread layerPainter4
---- thread parallelLoop
---- thread parallelLoop
---- thread parallelLoop
---- thread parallelLoop
---- thread main
---- thread layerPainter1
---- thread layerPainter2
---- thread layerPainter3
---- thread layerPainter4
---- thread parallelLoop
---- thread parallelLoop
---- thread parallelLoop
---- thread parallelLoop

Developer comments (common to all duplicates if any)

Still no comments.

Systems and versions

Linux
  Qt                  4.7.1
  QGpCoreTools        1.18.0 from geopsypack-2.1.0	(built on 201101031552)
  GeopsyCore          3.3.0 from geopsypack-2.1.0	(built on 201101031552)
  GeopsySLink         1.0.0 from geopsypack-2.1.0	(built on 201101031552)
  QGpGuiTools         1.10.0 from geopsypack-2.1.0	(built on 201101031552)
  SciFigs             2.3.0 from geopsypack-2.1.0	(built on 201101031552)
  GeopsyGui           2.8.0 from geopsypack-2.1.0	(built on 201101031552)
  GeopsySLinkGui      1.0.0 from geopsypack-2.1.0	(built on 201101031552)
  geopsy              2.7.0 from geopsypack-2.1.0	(built on 201101031552)
  DinverCore          0.9.0 from geopsypack-2.1.0	(built on 201101031552)
  QGpCoreWave         0.8.0 from geopsypack-2.1.0	(built on 201101031552)
  QGpCompatibility    0.3.0 from geopsypack-2.1.0	(built on 201101031552)
  DinverDCCore        1.5.0 from geopsypack-2.1.0	(built on 201101031552)
  ArrayCore           1.2.0 from geopsypack-2.1.0	(built on 201101031552)
  DinverGui           0.2.0 from geopsypack-2.1.0	(built on 201101031552)
  QGpGuiWave          0.6.0 from geopsypack-2.1.0	(built on 201101031552)
  ArrayGui            0.1.0 from geopsypack-2.1.0	(built on 201101031552)
  geopsyarray         2.2.0 from geopsypack-2.1.0	(built on 201101031552)
  MonoStation         1.5.0 from geopsypack-2.1.0	(built on 201101031552)
  geopsyhv            2.6.0 from geopsypack-2.1.0	(built on 201101031552)
  structureratios     0.5.0 from geopsypack-2.1.0	(built on 201101031552)

User comments

User reports

19162011-05-02 17:24:14