Contents

hide
<<previous   next>>

Bug 1714 :

Status: Obsolete

geopsy

General information

--FATAL ERROR-

Segmentation fault Signal

2011-06-06 23:34:10.413

main,layerPainter1

Current thread: main thread

---- thread main
double GeopsyCore::DoubleSignal::amplitude2(const double*, int) const:208
void GeopsyCore::DoubleSignal::copyAmplitudeFrom(const GeopsyCore::DoubleSignal*):1353
virtual void HVStationSignals::setProcessed(const GeopsyCore::TimeRange&, GeopsyCore::AbstractParameters*):45
void HVStation::computeHV(int, const GeopsyCore::TimeRange&, MonoStation::SpectrumParameters&):101
virtual void HVStation::start(MonoStation::SpectrumParameters&):59
virtual void MonoStation::AbstractTool::start():617
---- thread layerPainter1
void GeopsyGui::SignalLayer::drawSignal(const SciFigs::GraphContentOptions&, QPainter&, const GeopsyCore::Signal*, int, int, int, double, double, bool, double, int, bool, bool) const:457
virtual void GeopsyGui::SignalLayer::paintData(const SciFigs::LayerPainterRequest&, QPainter&, double) const:816
void SciFigs::GraphContentLayer::paint(const SciFigs::LayerPainterRequest&, QPainter&, double):199
void SciFigs::LayerPainterRequest::paintLayers(QPainter&):93
virtual void SciFigs::LayerPainterThread::run():59

---- thread main
---- thread layerPainter1
---- thread main
---- thread layerPainter1

Developer comments (common to all duplicates if any)

Still no comments.

Systems and versions

Windows Vista
  Qt                  4.6.3
  QGpCoreTools        1.19.0 from geopsypack-2.2.0	(built on 201102011712)
  GeopsyCore          3.3.1 from geopsypack-2.2.0	(built on 201102011722)
  QGpGuiTools         1.11.0 from geopsypack-2.2.0	(built on 201102011714)
  SciFigs             2.4.0 from geopsypack-2.2.0	(built on 201102011715)
  GeopsyGui           2.9.0 from geopsypack-2.2.0	(built on 201102011723)
  GeopsySLink         1.0.0 from geopsypack-2.2.0	(built on 201101031552)
  GeopsySLinkGui      1.0.0 from geopsypack-2.2.0	(built on 201101031552)
  geopsy              2.7.1 from geopsypack-2.2.0	(built on 201102011725)
  QGpCoreWave         0.8.1 from geopsypack-2.2.0	(built on 201102011716)
  ArrayCore           1.3.0 from geopsypack-2.2.0	(built on 201102011725)
  DinverCore          0.9.1 from geopsypack-2.2.0	(built on 201102011723)
  QGpCompatibility    0.3.0 from geopsypack-2.2.0	(built on 201101031552)
  DinverDCCore        1.5.0 from geopsypack-2.2.0	(built on 201101031552)
  QGpGuiWave          0.6.1 from geopsypack-2.2.0	(built on 201102011717)
  geopsyarray         2.3.0 from geopsypack-2.2.0	(built on 201102011727)
  MonoStation         1.6.0 from geopsypack-2.2.0	(built on 201102011725)
  geopsyhv            2.6.1 from geopsypack-2.2.0	(built on 201102011727)
  structureratios     0.5.1 from geopsypack-2.2.0	(built on 201102011728)

User comments

User reports

19662011-06-07 06:34:31