Contents

hide

2008-03-31: text and figures updated. Link to scifigs probably not correct. To fix once a definitive user documentation is available for figue and scifigs library.

4.4 Preferences

This section explains how to configure geopsy. Various settings can be adjusted within the graphical user interface. This section also explains how to deal with directory paths that are automatically saved during your work. For advanced users, the way the options are saved and how to change them are detailed.

Basic preferences dialog box

The preference dialog box is automatically displayed at startup when geopsy is installed on a new machine. You can avoid it by unchecking "Show this dialog on startup". To access it later, select menu "File/Preferences" (under Mac this item is under the Apple menu). The preference dialog box, shown in figures 1 to 6, contains several independent tabs explained hereafter.

The defaults values are usually valid for a majority of users. However, in certain circumstances or if you want to optimize your work with geopsy, it may be interesting to change these options. For instance, if you are dealing with signals recorded for refraction analysis, you may drop any reference to absolute time. In this case, on loading signals you have to choose option "No common time reference". By contrast, to process ambient vibrations, the best option is probably "Use this time" set to midnight.

Loading files

Loading files tab

Figure 1: Tab for changing the "Loading files" options.

These options apply to the loading of new files into the database (menu item "File/Import Signals/File").

File format

There are two exclusive options: either ask for the file format interactively or always use a given file format. "Automatic recognition" does not specify any special format but lets the automatic format recognition algorithm select the right formats of files. The rules for selecting formats are presented in section Automatic recognition. The default and mostly used option is the one presented in figure 1.

Time reference

The definition of the time reference is given in Database section. Either you can set the time reference interactively for each file ("Always ask ...") or you can skip this step. If not set interactively, the time reference is automatically deduced from the information contained in file headers. However, not all file formats have this kind of information available. The recording startup time, read until the seconds, is considered as the time reference. The remaining milliseconds are added to T0.

For signals recorded simultaneously but with distinct startup times (e.g. the time needed to manually start the recordings of stations synchronised by GPS), the time reference must identical for all stations. Hence, it is mandatory to force the time or eventually the date to a common reference. If all the signals were started the same day, you can use the default, shown in figure 1. The reference is set at midnight, and T0 is the number of seconds since midnight (including milli or micro seconds). If synchronous signals are distributed over several days, it is mandatory to force the date as well. Thus, you must edit this preference before loading the files for the first time.

Changing the time reference afterwards, once the signals are loaded, is possible but not strongly advised. Actually, when loading the files, T0 are automatically calculated from the true time of measurement and from the deduced or forced reference time. When editing the time reference in the database, T0 are left unchanged and it may lead to errors in signal synchronisations. We would recommend to edit the time reference only in a table containing all synchronous signals.

Viewing signals after loading

For some applications, especially if no database is created (single files mode), it may be appreciated to display a table or a graphic of the signals directly after loading the files. You can choose to open a table or a graphic, or both. A single window summarizing all files or one window per file may be created. This action can be performed only if less a certain number of files are opened together. To suppress all viewers after loading files, uncheck the checkbox "Do it only if less than".

Signal names

Names of signals are most of the time set to the name of station specified in file headers. If you do not want to extract this name and to leave the names as blank, uncheck the option "Use station names ...". For some interpretation tools, such as H/V, if the signal names are blank the signals are referenced by their file names.

In some cases (e.g. when loading files from CityShark 2), it may be interesting to automatically name the signals R001, R002,... For all file formats except CityShark, the index is the index of signal inside the file. For CityShark format with more than 3 channels, it is assumed that three-component sensors are used.

Saving files

Save tab

Figure 2: Tab for changing the "Save" options.

Geopsy offers an implicit way to save all modifications: the database. Here we make the distinction between modifications to signals header information and to signal samples. A modification of the signal samples is generally produced by any signal processing: e.g. filtering, tapering, cutting,... All these operations produce modified signals or create entirely new signals (with no physical storage, called "temporary signals" by contrast to "permanent files"). There are also acquisition modules (e.g. Cityshark loader) that can produce new virtual files (called "temporary files"). These temporary items exist as long as there references. Once all signals viewers containing them are closed, these items are deleted. To kept them permanently you must save the current database.

Click on menu "File/Save" to save all your modifications (headers and samples). Header information is stored in a database file with a .gpy extension. Modified samples must be written on a disk in a separate new file. Original files are never touched. The file name is chosen automatically with the pattern "processed_XXX", with XXX an arbitrary number. This preference tab lets you choose where to save these new signal files. The created files have a binary format (Database signals).

Temporary files and signals can be saved

Memory

Memory tab

Figure 3: Tab for changing the "Memory" options.

Geopsy is built upon a powerful mechanism for allocating memory for signal vectors. With this system, it is possible to view many signals over long periods at the same time. The program almost never ends with memory full errors, as a specific internal swap system ensures that the memory usage is limited. The size of this maximum is specified here. This is not a static memory allocation, hence, most of the time this amount of memory space is never used. However, for some computations, huge amounts of memory may be necessary (e.g. SPAC for long signals) and signals are efficiently swapped to the disk ("Swap folder" in figure 3).

The default value is 256 Mbytes (this number may change in the future as long as the capacity of standard computers evolves) which allows reasonable computations to be executed without swapping. However, to avoid swap and to speed up computations, it is better to exploit all resources of your computer. The best performances are obtained when the maximum memory size is a bit lower than the true physical memory size. Setting something greater than the physical memory is possible (if your operating system supports swap memory) but inefficient. Experience has proved that the system swap is less efficient that geopsy internal swap (the priority of memory blocks are set by the running process as a function of the future usage of the memory, not the case for system swap).

Table

Table tab

Figure 4: Tab for changing the "Table" options.

This tab specifies the information to display in all new tables. Each data field corresponds to one column in the tables. In the left column ("Data field"), the names of the internal variables chosen for display are listed. These internal variables are described here. On the right column ("Title"), the associated titles in the tables are listed. A default title is defined for all variable. You can change it to your best convenience.

New data fields can be added by clicking on "Add". It will be added at the end of the list. If one item in the list is selected, a new data field can be inserted ("Insert") before the current data field or it can be deleted ("Remove"). The combo in upper right corner lets you switch to pre-defined combinations: "Default", "All",... A system to save/restore custom configuration is still to implement.

Tools tab

Figure 5: Tab for changing the "Tools" options.

Tools

This tab helps you configuring the "Tools" menu. "Tools" menu lets you start specific processing tools developed as plug-ins. Plug-ins are dynamic libraries containing executable code that can be added to geopsy without recompiling the core program. The available tools that are listed in "Tools" menu are managed in this tab. The most often used "Tools" are available in the context menu displayed when clicking on the mouse right button in the "Files" and "Groups" lists.

To add a new tool, you first have to download and to install the corresponding library on your computer. The location of the library in the file hierarchy is arbitrary. Tools are not added individually but they are automatically loaded after searching into some defined directories. They are specified in the second part of the dialog box shown in figure 5. Click on "Add" or "Remove" to manage the list of paths to search. If you add new plugins to these paths, click on "Search" to update the list of tools (upper part in figure 5).

You can remove useless plugins manually by hitting "Remove". You can re-arrange the tools by selecting one and by moving upwards or downwards ("Up" or "Down" arrows). You can also add separators (horizontal lines in menus) to better separate categories of tools. Any change to the tool list will be effective for next geopsy startup.

Preference tabs from Plugins

The preference dialog box may also contains additional tabs linked to loaded plugins.

H/V and Structure

H/V tab

Figure 6: Tab for changing the "H/V" options.

These tabs are present only if you add the "H/V" tool or "Structure" tool. It lets you configure the graphical outputs. The "H/V" tool produces basically two kinds of graphical outputs: H/V spectra and component spectra. These graphical outputs contains XY plots with various layers (see scifigs documentation for details). For each plot, you can select which layer you want to see. These options are detailed in the H/V tools specific section.

Directory paths

Quickly jumping to frequently used directories

Figure 7: Quickly jumping to frequently used directories in the file dialog box.

Each time you select a file to open or to save, geopsy automatically stores the path of the selected file. The next time you will open or save the same type of file, the dialog box will start on this directory avoiding fastidious clicks to move from your home or your "My Documents" directory to your working directory. Furthermore, every visited directory for this type of files is stored in the combobox at the top of the dialog box (figure 7). You can them quickly jump to a frequently used directory. Just after "Recent places", you have the current directory followed by the history of the last visited directories (3 entries for all file types followed by 17 entries for the current file type).

Storage of settings

The default values appearing in dialog boxes displayed by geopsy are always equal to the preceding values set by the user for these items. These values are stored in file "$HOME/.config/geopsy/geopsy.conf", under the label "[DialogOptions]". If you want to remove all user settings and return to the original default, close all instances of geopsy and remove all entries under "[DialogOptions]". Removing the directory "$HOME/.config/geopsy" and the file "$HOME/.config/geopsy.conf" has the same effect but also resets other stored settings. Under Windows, the same reset can be done by removing key entries in the registry (with regedt32, key "HKEY_CURRENT_USER/software/geopsy").