Installation problem (Ubuntu 16.04 LTS)

Post in this forum any question related to the installation on any of the supported platforms (Linux, Mac OS X, Windows)
Post Reply
FrenchRems
Posts: 3
Joined: Fri Apr 17, 2020 1:25 pm

Installation problem (Ubuntu 16.04 LTS)

Post by FrenchRems »

Hi everyone,

I am a Windows friendly user, and I am struggling to instal and download Geopsy.
First, I downloaded the package (from the page http://www.geopsy.org/download.php), in the path : /home/remi/anaconda3/envs/obspy/geopsypack-src-3.2.2
From this folder, I read the "INSTALL" file, and follow the configuration step, by taping in the terminal : "./configure". At the end of the configuration, I receive the message : "GeopsyPack is now configured for building.". But then, when I excecuted "make -j 8" in the terminal (or even only "make", which is only slower), I end up with the error message (see the attached screenshot).

I am sorry that the message is in French, but "a échoué" means "has failed", "ne peut trouver" means "can't find", "on quitte / on entre dans le répertoire" means "entering / quitting the directory".

I hope this is a classic error (even if I couldn't find any solution on the internet so far, nor this FAQ). Hoping for your help :)

Have a nice day between,

Rémi
Attachments
error_msg.png
(440.5 KiB) Not downloaded yet

FrenchRems
Posts: 3
Joined: Fri Apr 17, 2020 1:25 pm

Re: Installation problem (Ubuntu 16.04 LTS)

Post by FrenchRems »

Hi everyone,

I have partially solved the problem, by intalling again the missing "-llapack" and "-lblas" libraries. By now, when I start the "make", I get :

g++: error: /home/remi/anaconda3/envs/obspy/bin/../x86_64-conda_cos6-linux-gnu/sysroot/usr/lib64/libGL.so: Aucun fichier ou dossier de ce type
Makefile.Release:621 : la recette pour la cible « ../lib/libQGpGuiTools.so.2.2.0 » a échouée
make[2]: *** [../lib/libQGpGuiTools.so.2.2.0] Erreur 1
make[2] : on quitte le répertoire « /home/remi/anaconda3/envs/obspy/geopsypack-src-3.2.2/QGpGuiTools »
Makefile:42 : la recette pour la cible « release » a échouée
make[1]: *** [release] Erreur 2
make[1] : on quitte le répertoire « /home/remi/anaconda3/envs/obspy/geopsypack-src-3.2.2/QGpGuiTools »
Makefile:210 : la recette pour la cible « sub-QGpGuiTools-make_first-ordered » a échouée
make: *** [sub-QGpGuiTools-make_first-ordered] Erreur 2


I noticed that some people have seen my message but didno't answer. Do someone has the answer?

Have a nice day guys and thank you in advance, because I really need a solution quickly unfortunately...

Rémi

FrenchRems
Posts: 3
Joined: Fri Apr 17, 2020 1:25 pm

Re: Installation problem (Ubuntu 16.04 LTS)

Post by FrenchRems »

By the way, the output of "conda list" is this :

# packages in environment at /home/remi/anaconda3/envs/obspy:
#
# Name Version Build Channel
_libgcc_mutex 0.1 conda_forge conda-forge
_openmp_mutex 4.5 0_gnu conda-forge
alabaster 0.7.12 py_0 conda-forge
astroid 2.3.3 py37_1 conda-forge
attrs 19.3.0 py_0 conda-forge
babel 2.8.0 py_0 conda-forge
backcall 0.1.0 py_0 conda-forge
basemap 1.2.0 py37hd759880_4 conda-forge
bleach 3.1.0 py_0 conda-forge
ca-certificates 2019.11.28 hecc5488_0 conda-forge
certifi 2019.11.28 py37_0 conda-forge
cffi 1.13.2 py37h8022711_0 conda-forge
chardet 3.0.4 py37_1003 conda-forge
cloudpickle 1.2.2 py_1 conda-forge
control 0.8.3 py37_1 conda-forge
cryptography 2.8 py37h72c5cf5_1 conda-forge
cycler 0.10.0 py_2 conda-forge
dbus 1.13.6 he372182_0 conda-forge
decorator 4.4.1 py_0 conda-forge
defusedxml 0.6.0 py_0 conda-forge
docutils 0.16 py37_0 conda-forge
entrypoints 0.3 py37_1000 conda-forge
expat 2.2.9 he1b5a44_2 conda-forge
fontconfig 2.13.1 h86ecdb6_1001 conda-forge
freetype 2.10.0 he983fc9_1 conda-forge
future 0.18.2 py37_0 conda-forge
geos 3.7.2 he1b5a44_2 conda-forge
gettext 0.19.8.1 hc5be6a0_1002 conda-forge
glib 2.58.3 py37h6f030ca_1002 conda-forge
gst-plugins-base 1.14.5 h0935bb2_1 conda-forge
gstreamer 1.14.5 h36ae1b5_1 conda-forge
icu 64.2 he1b5a44_1 conda-forge
idna 2.8 py37_1000 conda-forge
imagesize 1.2.0 py_0 conda-forge
importlib_metadata 1.5.0 py37_0 conda-forge
inflect 4.1.0 py37_0 conda-forge
ipykernel 5.1.4 py37h5ca1d4c_0 conda-forge
ipython 7.12.0 py37h5ca1d4c_0 conda-forge
ipython_genutils 0.2.0 py_1 conda-forge
isort 4.3.21 py37_0 conda-forge
jaraco.itertools 5.0.0 py_0 conda-forge
jedi 0.16.0 py37_0 conda-forge
jeepney 0.4.2 py_0 conda-forge
jinja2 2.11.1 py_0 conda-forge
jpeg 9c h14c3975_1001 conda-forge
json5 0.9.0 py_0 conda-forge
jsonschema 3.2.0 py37_0 conda-forge
jupyter_client 5.3.4 py37_1 conda-forge
jupyter_core 4.6.1 py37_0 conda-forge
jupyterlab 1.2.6 py_0 conda-forge
jupyterlab_server 1.0.6 py_0 conda-forge
keyring 21.1.0 py37_0 conda-forge
kiwisolver 1.1.0 py37hc9558a2_0 conda-forge
lazy-object-proxy 1.4.3 py37h516909a_1 conda-forge
ld_impl_linux-64 2.33.1 h53a641e_8 conda-forge
libblas 3.8.0 14_openblas conda-forge
libcblas 3.8.0 14_openblas conda-forge
libclang 9.0.1 default_hde54327_0 conda-forge
libffi 3.2.1 he1b5a44_1006 conda-forge
libgcc-ng 9.2.0 h24d8f2e_2 conda-forge
libgfortran-ng 7.3.0 hdf63c60_5 conda-forge
libgomp 9.2.0 h24d8f2e_2 conda-forge
libiconv 1.15 h516909a_1005 conda-forge
liblapack 3.8.0 14_openblas conda-forge
libllvm9 9.0.1 hc9558a2_0 conda-forge
libopenblas 0.3.7 h5ec1e0e_6 conda-forge
libpng 1.6.37 hed695b0_0 conda-forge
libsodium 1.0.17 h516909a_0 conda-forge
libstdcxx-ng 9.2.0 hdf63c60_2 conda-forge
libuuid 2.32.1 h14c3975_1000 conda-forge
libxcb 1.13 h14c3975_1002 conda-forge
libxkbcommon 0.9.1 hebb1f50_0 conda-forge
libxml2 2.9.10 hee79883_0 conda-forge
libxslt 1.1.33 h31b3aaa_0 conda-forge
lxml 4.5.0 py37h7ec2d77_0 conda-forge
markupsafe 1.1.1 py37h516909a_0 conda-forge
matplotlib 3.1.3 py37_0 conda-forge
matplotlib-base 3.1.3 py37h250f245_0 conda-forge
mccabe 0.6.1 py_1 conda-forge
mistune 0.8.4 py37h516909a_1000 conda-forge
more-itertools 8.2.0 py_0 conda-forge
nbconvert 5.6.1 py37_0 conda-forge
nbformat 5.0.4 py_0 conda-forge
ncurses 6.1 hf484d3e_1002 conda-forge
notebook 6.0.3 py37_0 conda-forge
nspr 4.24 he1b5a44_0 conda-forge
nss 3.47 he751ad9_0 conda-forge
numpy 1.15.4 py37h8b7e671_1002 conda-forge
numpydoc 0.9.2 py_0 conda-forge
obspy 1.1.1 py37h3010b51_1 conda-forge
opencv-python 4.2.0.34 pypi_0 pypi
openssl 1.1.1d h516909a_0 conda-forge
packaging 20.1 py_0 conda-forge
pandoc 2.9.1.1 0 conda-forge
pandocfilters 1.4.2 py_1 conda-forge
parso 0.6.1 py_0 conda-forge
pcre 8.43 he1b5a44_0 conda-forge
pexpect 4.8.0 py37_0 conda-forge
pickleshare 0.7.5 py37_1000 conda-forge
pip 20.0.2 py37_1 conda-forge
proj4 4.9.3 h516909a_9 conda-forge
prometheus_client 0.7.1 py_0 conda-forge
prompt_toolkit 3.0.3 py_0 conda-forge
psutil 5.6.7 py37h516909a_0 conda-forge
pthread-stubs 0.4 h14c3975_1001 conda-forge
ptyprocess 0.6.0 py_1001 conda-forge
pycodestyle 2.5.0 py_0 conda-forge
pycparser 2.19 py37_1 conda-forge
pyflakes 2.1.1 py_0 conda-forge
pygments 2.5.2 py_0 conda-forge
pylint 2.4.4 py37_0 conda-forge
pyopenssl 19.1.0 py37_0 conda-forge
pyparsing 2.4.6 py_0 conda-forge
pyproj 1.9.5.1 py37h2944ce7_1006 conda-forge
pyqt 5.12.3 py37hcca6a23_1 conda-forge
pyqt5-sip 4.19.18 pypi_0 pypi
pyqtwebengine 5.12.1 pypi_0 pypi
pyrsistent 0.15.7 py37h516909a_0 conda-forge
pyshp 2.1.0 py_0 conda-forge
pysocks 1.7.1 py37_0 conda-forge
python 3.7.6 h357f687_2 conda-forge
python-dateutil 2.8.1 py_0 conda-forge
pytz 2019.3 py_0 conda-forge
pyzmq 18.1.1 py37h1768529_0 conda-forge
qt 5.12.5 hd8c4c69_1 conda-forge
qtawesome 0.6.1 py_0 conda-forge
qtconsole 4.6.0 py_0 conda-forge
qtpy 1.9.0 py_0 conda-forge
readline 8.0 hf8c457e_0 conda-forge
requests 2.22.0 py37_1 conda-forge
rope 0.16.0 py_0 conda-forge
scipy 1.4.1 py37h921218d_0 conda-forge
secretstorage 3.1.2 py37_0 conda-forge
send2trash 1.5.0 py_0 conda-forge
setuptools 45.1.0 py37_0 conda-forge
six 1.14.0 py37_0 conda-forge
slycot 0.3.5.0 py37h950b918_2 conda-forge
snowballstemmer 2.0.0 py_0 conda-forge
sphinx 2.3.1 py_0 conda-forge
sphinxcontrib-applehelp 1.0.1 py_0 conda-forge
sphinxcontrib-devhelp 1.0.1 py_0 conda-forge
sphinxcontrib-htmlhelp 1.0.2 py_0 conda-forge
sphinxcontrib-jsmath 1.0.1 py_0 conda-forge
sphinxcontrib-qthelp 1.0.2 py_0 conda-forge
sphinxcontrib-serializinghtml 1.1.3 py_0 conda-forge
spyder 3.3.6 py37_0
spyder-kernels 0.5.2 py37_0
sqlalchemy 1.3.13 py37h516909a_0 conda-forge
sqlite 3.30.1 hcee41ef_0 conda-forge
terminado 0.8.3 py37_0 conda-forge
testpath 0.4.4 py_0 conda-forge
tk 8.6.10 hed695b0_0 conda-forge
tornado 6.0.3 py37h516909a_0 conda-forge
traitlets 4.3.3 py37_0 conda-forge
typed-ast 1.4.1 py37h516909a_0 conda-forge
urllib3 1.25.7 py37_0 conda-forge
wcwidth 0.1.8 py_0 conda-forge
webencodings 0.5.1 py_1 conda-forge
wheel 0.34.2 py37_0 conda-forge
wrapt 1.11.2 py37h516909a_0 conda-forge
wurlitzer 2.0.0 py37_0 conda-forge
xorg-libxau 1.0.9 h14c3975_0 conda-forge
xorg-libxdmcp 1.1.3 h516909a_0 conda-forge
xz 5.2.4 h14c3975_1001 conda-forge
zeromq 4.3.2 he1b5a44_2 conda-forge
zipp 2.1.0 py_0 conda-forge
zlib 1.2.11 h516909a_1006 conda-forge

admin
Site Admin
Posts: 432
Joined: Mon Aug 13, 2007 11:48 am
Location: ISTerre
Contact:

Re: Installation problem (Ubuntu 16.04 LTS)

Post by admin »

Hi,

reading your numerous posts, it is unclear if you are compiling under a classical Ubuntu environment or if it is linked to anaconda (I've never used it and I do not know what could be the effects on geopsy compilation.

Just a prerequisite, did you installed the packages listed there?

The missing libGL.so is linked to graphical part of Qt libraries. Apparently, all core libraries were fine but it blocks at the first GUI library.

Marc

Post Reply