Installation problems

Post in this forum any question related to the installation on any of the supported platforms (Linux, Mac OS X, Windows)
Luciana Cantore
Posts: 3
Joined: Wed Apr 16, 2014 5:00 pm

Installation problems

Postby Luciana Cantore » Tue May 13, 2014 10:35 am

Hello admin,
I'm working as researcher at Istituto Nazionale di Geofisica e Vulcanologia Roma, Italy, and I deal of site effects.
This is my problem during installation:
I configure script, when done I install geopsypack (make install)

This is the error:

src/AbstractStream.h: In member function ‘QGpCoreTools::AbstractStream& QGpCoreTools::AbstractStream::operator<<(char)’:
src/AbstractStream.h:59:69: error: ‘fromAscii’ is not a member of ‘QChar’
AbstractStream& operator<<(char val) {return operator<<(QString(QChar::fromAscii(val)));}

Do you have any suggestion?
thanks

sbirro
Posts: 7
Joined: Tue Dec 27, 2011 2:10 pm

Re: Installation problems

Postby sbirro » Wed May 14, 2014 6:31 am

I'm not sure it will solve the problem, but check your version of the QT libraries. It should be 4.6.3 or greater.

Luciana Cantore
Posts: 3
Joined: Wed Apr 16, 2014 5:00 pm

Re: Installation problems

Postby Luciana Cantore » Wed May 14, 2014 7:06 am

Qt version is 4.8.1

sbirro
Posts: 7
Joined: Tue Dec 27, 2011 2:10 pm

Re: Installation problems

Postby sbirro » Wed May 14, 2014 8:17 am

Please try to open the file "AbstractStream.h" in the folder "/QGpCoreTools/src" and replace "fromAscii" with "fromLatin1" at the line 59.

Luciana Cantore
Posts: 3
Joined: Wed Apr 16, 2014 5:00 pm

Re: Installation problems

Postby Luciana Cantore » Thu May 15, 2014 7:08 am

Hello,
I tried your suggestion, but I have a new error message:

make[2]: ingresso nella directory "/home/luciana/Scrivania/geopsypack-57items-src-2.4.4/QGpCoreTools"
g++ -c -m64 -pipe -O2 -Wall -W -D_REENTRANT -fPIC -DMAKE_QGPCORETOOLS_DLL -DQT_NO_DEBUG -DQT_CORE_LIB -I/usr/share/qt5/mkspecs/linux-g++-64 -I. -Isrc -Iui -I../include -I/usr/include/qt5 -I/usr/include/qt5/QtCore -Irelease -o release/Cache.o src/Cache.cpp
src/Cache.cpp: In member function ‘bool QGpCoreTools::Cache::makeAvailable(const QGpCoreTools::CacheItem*)’:
src/Cache.cpp:199:65: error: ‘class QString’ has no member named ‘toAscii’
CoreApplication::instance()->reportBug( Message::Warning, msg.toAscii().data() );
^
src/Cache.cpp: In member function ‘bool QGpCoreTools::Cache::enlarge(QGpCoreTools::CacheItem*, double)’:
src/Cache.cpp:226:69: error: ‘class QString’ has no member named ‘toAscii’
CoreApplication::instance()->reportBug( Message::Warning, msg.toAscii().data() );
^
make[2]: *** [release/Cache.o] Errore 1
make[2]: uscita dalla directory "/home/luciana/Scrivania/geopsypack-57items-src-2.4.4/QGpCoreTools"
make[1]: *** [release-install] Errore 2
make[1]: uscita dalla directory "/home/luciana/Scrivania/geopsypack-57items-src-2.4.4/QGpCoreTools"
make: *** [sub-QGpCoreTools-install_subtargets-ordered] Errore 2

Do you have any suggestions?
Cheers, Luciana

sbirro
Posts: 7
Joined: Tue Dec 27, 2011 2:10 pm

Re: Installation problems

Postby sbirro » Thu May 15, 2014 9:22 am

Same error, at lines 199 and 226 of the file "Cache.cpp".

I have to warn you that I'm actually not an expert of Qt development and I can not guarantee that these edits are without side effects, although they seem safe (see here.)

admin
Site Admin
Posts: 407
Joined: Mon Aug 13, 2007 11:48 am
Location: ISTerre
Contact:

Re: Installation problems

Postby admin » Mon Dec 05, 2016 9:43 am

If you are using Qt 5, you should try only the "devel" release. The current "testing" release supports only Qt4.

To check your Qt version, run:

Code: Select all

$ qmake -v
QMake version 2.01a
Using Qt version 4.8.6 in /usr/lib64/qt4


Return to “Installation”

Who is online

Users browsing this forum: No registered users and 1 guest