Problem with the installation during make

Post in this forum any question related to the installation on any of the supported platforms (Linux, Mac OS X, Windows)
tahoser
Posts: 5
Joined: Thu Mar 05, 2009 3:25 pm

Problem with the installation during make

Postby tahoser » Fri May 29, 2009 3:06 pm

Hi Marc,

This the error message I have when I try to install geopsy. I have it after the ./configure and during the make:




/usr/local/Trolltech/Qt-4.5.0/include/QtCore/qvariant.h: In member function ‘virtual void QtbSignalLayer::properties(QtbPropertyWidget*) const’:
/usr/local/Trolltech/Qt-4.5.0/include/QtCore/qvariant.h:413: erreur: ‘QVariant::QVariant(void*)’ is private
qtbsignallayer.cpp:1296: erreur: à l'intérieur du contexte
make[2]: *** [../.obj/release/qtbsignallayer.o] Erreur 1
make[2]: quittant le répertoire « /home/crose/Téléchargement/sesarray-src-2.0.5/src/geopsygui/src »
make[1]: *** [first] Erreur 2
make[1]: quittant le répertoire « /home/crose/Téléchargement/sesarray-src-2.0.5/src/geopsygui »
make: *** [geopsygui] Erreur 2





Thank you very much for your precious help!

Estelle

admin
Site Admin
Posts: 412
Joined: Mon Aug 13, 2007 11:48 am
Location: ISTerre
Contact:

Postby admin » Sun May 31, 2009 9:08 pm

sesarray-2.0.5 has never been compiled against Qt 4.5.0. I expect errors. Currently 2.0.6 is available as well as 2.1.0. They are both tested and developed against Qt 4.5.0.

dmikesell
Posts: 1
Joined: Fri May 29, 2009 7:57 pm
Location: Boise, Idaho

Postby dmikesell » Mon Jun 01, 2009 2:45 pm

I am new to geopsy and tried installing for the first time on Friday.
I had this same problem on Friday when I tried compiling 2.0.5. I am happy to try 2.0.6 or 2.1.0, but I can't find either of those for download. How I can get one of those?
Many thanks for your help and this software. I am excited to try it out once I get it complied.
Thanks,
Dylan

admin
Site Admin
Posts: 412
Joined: Mon Aug 13, 2007 11:48 am
Location: ISTerre
Contact:

Postby admin » Mon Jun 01, 2009 6:16 pm

Current stable release (2.0.5) cannot be compiled with latest Qt release (4.5.X). Release 2.0.5 has been developed with Qt 4.3.3 that you'll find at
ftp://ftp.qtsoftware.com/qt/source/qt-x ... 3.3.tar.gz

tahoser
Posts: 5
Joined: Thu Mar 05, 2009 3:25 pm

New problem with the installation

Postby tahoser » Thu Jun 11, 2009 2:12 pm

This the new error message I have when I try ti install the new version of geopsy:


/usr/bin/ld: cannot find -llapack
collect2: ld a retourné 1 code d'état d'exécution
make[2]: *** [../lib/libmultistation.so.1.2.0] Erreur 1
make[2]: quittant le répertoire « /home/crose/Téléchargement/geopsypack-39items-src-2.1.0-snapshot-20090521/multistation »
make[1]: *** [release] Erreur 2
make[1]: quittant le répertoire « /home/crose/Téléchargement/geopsypack-39items-src-2.1.0-snapshot-20090521/multistation »
make: *** [sub-multistation-make_default-ordered] Erreur 2

admin
Site Admin
Posts: 412
Joined: Mon Aug 13, 2007 11:48 am
Location: ISTerre
Contact:

Postby admin » Thu Jun 11, 2009 2:17 pm

You can follow the instructions at http://www.geopsy.org/wiki/index.php/Installation:Linux

This is the new documentation being built... soon available under tab 'Documentation'.

If you need more information, you can contribute to the documentation with your own experience (create an account on the wiki first). Or alternatively, report further questions in this forum, I'll forward them to the wiki.


Return to “Installation”

Who is online

Users browsing this forum: No registered users and 2 guests