Problems with geopsy installation on CentOS 5.7

Post in this forum any question related to the installation on any of the supported platforms (Linux, Mac OS X, Windows)
Post Reply
Posts: 1
Joined: Fri Dec 16, 2011 10:02 pm

Problems with geopsy installation on CentOS 5.7

Post by usgsuser »


I'm installing geopsy on CentOS 5.7. I've installed the latest version of Qt from the Nokia site.

I'm still running into problems with the freetype library thought.. When I compile I get the following error.

Here is the output of my configure..

[root@localhost geopsypack-57items-src-2.4.2]# ./configure

Configure QGpCoreTools
Configure QGpGuiTools
Configure SciFigs
Configure DinverCore
Configure DinverGui
Configure dinver
Configure QGpCoreWave
Configure QGpGuiWave
Configure QGpCompatibility
Configure DinverDCCore
Configure DinverDCGui
Configure dinverdc
Configure dinverext
Configure dinvermatlab
Configure fastmap
Configure figue
Configure dfftpack
Configure mseed
Configure GeopsyCore
Configure GeopsyGui
Configure slink
Configure GeopsySLink
Configure GeopsySLinkGui
Configure geopsy
Configure ArrayCore
Configure ArrayGui
Configure geopsyarray
Configure geopsydamping
Configure geopsyfigs
Configure MonoStation
Configure geopsyhv
Configure geopsynr
Configure geopsyptmotion
Configure geopsyrefra
Configure geopsytfa
Configure gpcoord
Configure gpcurve
Configure gpdc
Configure gpdcmisfit
Configure gpdcreport
Configure gpdepths
Configure gpdistance
Configure gpec8
Configure gpell
Configure gpfksimulator
Configure gpgroup2phase
Configure gphistogram
Configure gplivemodel
Configure gpmodel2param
Configure gpparam2model
Configure gppoisson
Configure gpprofile
Configure gprandom
Configure gprefra
Configure gpreplace
Configure gpsh
Configure gpsignal
Configure gpsort
Configure gpspac
Configure gptarget
Configure gptime
Configure gptomoinfo
Configure gpviewdcreport
Configure kephren_plugin
Configure kephrenrtu
Configure max2curve
Configure spac2disp
Configure structureratios
Configure swim
Configure vslarray
Configure waran
Configure warand
Configure WaranCore
Configure warangps
Configure GpCoreTools
Configure warangpsd
Configure waranmon
Configure waranmond
Configure waranrouted

GeopsyPack is now configured for building, Just run 'make'.
Once everything is built, you must run either

$ su -c make install, if root privileges are needed;
$ make install, if user permissions are sufficient.

The current configuration options are stored in 'configure.cache'.
To change the configuration, run './configure [options]'.


Here is the error I get from my make..


/opt/QtSDK/Desktop/Qt/474/gcc/lib/ undefined reference to `FcFreeTypeQueryFace'
/opt/QtSDK/Desktop/Qt/474/gcc/lib/ undefined reference to `FT_Library_SetLcdFilter'
collect2: ld returned 1 exit status
make[2]: *** [../bin/dinver] Error 1
make[2]: Leaving directory `/home/usgsuser/Downloads/geopsypack-57items-src-2.4.2/dinver'
make[1]: *** [release] Error 2
make[1]: Leaving directory `/home/usgsuser/Downloads/geopsypack-57items-src-2.4.2/dinver'
make: *** [sub-dinver-make_default-ordered] Error 2

Do any of you have ideas on what could be causing this? I've tried doing the tricks as described in ... eQueryFace. I'm still having no luck.

Site Admin
Posts: 501
Joined: Mon Aug 13, 2007 11:48 am
Location: ISTerre

Re: Problems with geopsy installation on CentOS 5.7

Post by admin »

We are also running CentOS on the lab servers and I remember a problem like this when I compiled Geopsy some one or two years ago. I guess that if your try to run "designer" from Qt library package, it is the same result.

Can you install Qt libraries through CentOS instead of downloading it from Qt?
What is the available Qt release?
Did you compile Qt or did you install a binary package?
I cannot find my email exchanges about this problem, but it was linked to a too old version of fontconfig in CentOS. Try to compile a recent version of fontconfig, mine under Gentoo is fontconfig-2.8.0

Post Reply