Installation problem (centos7 / qt5.12.x)

Post in this forum any question related to the installation on any of the supported platforms (Linux, Mac OS X, Windows)
Post Reply
seguuu91
Posts: 4
Joined: Wed Apr 22, 2020 12:00 pm

Installation problem (centos7 / qt5.12.x)

Post by seguuu91 »

Dear,
I have a problem with installing Geopsy3.3.0.

I'm using centos 7 / qt5.12.x(I tried with several qt versions, 5.11.5/5.12.9/5.12.2, etc).
gcc 4.8.5 / gfortran 4.8.5.
With this condition, I'm struggling with an error like below for more than a week.
While 'make'
##########################################################################
make[1]: Entering directory `/Master/SOURCE/GEOPSY/geopsypack-src-3.3.0/gpdcreport'
g++ -c -pipe -O2 -std=gnu++11 -Wall -W -D_REENTRANT -fPIC -DQT_NO_DEBUG -DQT_CORE_LIB -I. -I/home/seguuu/Master/SOURCE/GEOPSY/geopsypack-src-3.3.0/gpdcreport/src -Isrc -I/home/seguuu/Master/SOURCE/GEOPSY/geopsypack-src-3.3.0/QGpCoreTools/src -I/home/seguuu/Master/SOURCE/GEOPSY/geopsypack-src-3.3.0/QGpCoreMath/src -I/home/seguuu/Master/SOURCE/GEOPSY/geopsypack-src-3.3.0/QGpCompatibility/src -I/home/seguuu/Master/SOURCE/GEOPSY/geopsypack-src-3.3.0/QGpCoreWave/src -I/home/seguuu/Master/SOURCE/GEOPSY/geopsypack-src-3.3.0/DinverCore/src -I/home/seguuu/Master/SOURCE/GEOPSY/geopsypack-src-3.3.0/DinverDCCore/src -I/opt/QT/qt5.12.2/5.12.2/gcc_64/include -I/opt/QT/qt5.12.2/5.12.2/gcc_64/include/QtCore -I. -I/opt/QT/qt5.12.2/5.12.2/gcc_64/mkspecs/linux-g++ -o main.o /home/seguuu/Master/SOURCE/GEOPSY/geopsypack-src-3.3.0/gpdcreport/src/main.cpp
~/Master/SOURCE/GEOPSY/geopsypack-src-3.3.0/gpdcreport/src/main.cpp:129:2: error: #error
make[1]: *** [main.o] Error 1
make[1]: Leaving directory `/Master/SOURCE/GEOPSY/geopsypack-src-3.3.0/gpdcreport'
make: *** [sub-gpdcreport-make_first-ordered] Error 2
##########################################################################
I tried installing with qt versions of 5.11.3, 5.12.2, 5.12.9 and 5.12.5(conda install)
Anyone help me plz.

seguuu91
Posts: 4
Joined: Wed Apr 22, 2020 12:00 pm

Re: Installation problem (centos7 / qt5.12.x)

Post by seguuu91 »

I finally Installed geopsy with 3.2.2.
But still, the 3.3.0 is not possible to be installed with the error.

Please anyone help me.
I need to use the latest version.
Last edited by seguuu91 on Sat Jul 04, 2020 10:04 am, edited 1 time in total.

seguuu91
Posts: 4
Joined: Wed Apr 22, 2020 12:00 pm

Re: Installation problem (centos7 / qt5.12.x)

Post by seguuu91 »

The problem was the version of gcc.

I updated the version to 8.3.1 then it worked.

Thanks.

Post Reply