ERROR INSTALLATION IN UBUNTU 20.04

Post in this forum any question related to the installation on any of the supported platforms (Linux, Mac OS X, Windows)
Post Reply
chasananda
Posts: 3
Joined: Wed Aug 19, 2020 9:21 am

ERROR INSTALLATION IN UBUNTU 20.04

Post by chasananda »

Hello Marc,

I was trying to install geopsy software, but when I ran

Code: Select all

sudo make install
the following error occured:

Code: Select all

cd mseed/ && ( test -e Makefile || /usr/lib/qt5/bin/qmake -o Makefile /opt/geopsy-3.3.0/mseed/mseed.pro ) && make -f Makefile install
make[1]: Entering directory '/opt/geopsy-3.3.0/mseed'
[ -d /opt/geopsy-3.3.0/lib ] || mkdir -p /opt/geopsy-3.3.0/lib
cp /opt/geopsy-3.3.0/lib/libmseed.a /opt/geopsy-3.3.0/lib
cp: '/opt/geopsy-3.3.0/lib/libmseed.a' and '/opt/geopsy-3.3.0/lib/libmseed.a' are the same file
make[1]: *** [Makefile:30: install] Error 1
make[1]: Leaving directory '/opt/geopsy-3.3.0/mseed'
Geopsy .v3.3.0
QMake version 3.1
Using Qt version 5.12.8 in /usr/lib/x86_64-linux-gnu
gcc (Ubuntu 9.3.0-10ubuntu2) 9.3.0

Could you please help me to fix those problems?
Thank you

admin
Site Admin
Posts: 501
Joined: Mon Aug 13, 2007 11:48 am
Location: ISTerre
Contact:

Re: ERROR INSTALLATION IN UBUNTU 20.04

Post by admin »

Hi,

Can you try with 3.3.2 or even better from the git repository with 3.3.3-preview?
See download page to access the git repository.

Marc

chasananda
Posts: 3
Joined: Wed Aug 19, 2020 9:21 am

Re: ERROR INSTALLATION IN UBUNTU 20.04

Post by chasananda »

Hi Marc,

I tried Geopsy 3.3.2 then I got the same problem.

Code: Select all

cd mseed/ && ( test -e Makefile || /opt/Qt/5.15.0/gcc_64/bin/qmake -o Makefile /opt/geopsy-3.3.2/mseed/mseed.pro ) && make -f Makefile install
make[1]: Entering directory '/opt/geopsy-3.3.2/mseed'
[ -d /opt/geopsy-3.3.2/lib ] || mkdir -p /opt/geopsy-3.3.2/lib
cp /opt/geopsy-3.3.2/lib/libmseed.a /opt/geopsy-3.3.2/lib
cp: '/opt/geopsy-3.3.2/lib/libmseed.a' and '/opt/geopsy-3.3.2/lib/libmseed.a' are the same file
make[1]: *** [Makefile:30: install] Error 1
make[1]: Leaving directory '/opt/geopsy-3.3.2/mseed'
make: *** [Makefile:152: sub-mseed-install_subtargets-ordered] Error 2
I haven't try Geopsy 3.3.3-preview but I will try it. I really don't have a clue with this problem. Is it from the os that I used or maybe from the Qt? Could you please give me any suggestions?

Thank you.
Nanda

chasananda
Posts: 3
Joined: Wed Aug 19, 2020 9:21 am

Re: ERROR INSTALLATION IN UBUNTU 20.04

Post by chasananda »

Hi Marc,

Code: Select all

In file included from ../../QGpCoreTools/src/XMLClass.h:35,
                 from ../../QGpCoreTools/src/ColumnTextDescription.h:32,
                 from ../../QGpCoreTools/src/QGpCoreTools.h:19,
                 from ../../gpcurve/src/CurveReader.cpp:27:
../../QGpCoreTools/src/XMLMember.h:77:13: note: because ‘QGpCoreTools::XMLMember’ has user-provided ‘void QGpCoreTools::XMLMember::operator=(const QGpCoreTools::XMLMember&)’
   77 | inline void XMLMember::operator=(const XMLMember& o)
      |             ^~~~~~~~~
make[1]: *** [Makefile:1142: CurveReader.o] Error 1
make[1]: *** Waiting for unfinished jobs....
make[1]: Leaving directory '/opt/geopsypack/geopsy-src/gpcurve'
make: *** [Makefile:2837: sub-gpcurve-make_first-ordered] Error 2
make: Leaving directory '/opt/geopsypack/geopsy-src'
when I ran

Code: Select all

make -j 8 -C /path/where/you/want/to/build
I'm sorry about this issue because I installed Geopsy 3.4, so this question isn't relevant anymore.
Last edited by chasananda on Wed Aug 26, 2020 8:40 am, edited 1 time in total.

chasananda
Posts: 3
Joined: Wed Aug 19, 2020 9:21 am

Re: ERROR INSTALLATION IN UBUNTU 20.04

Post by chasananda »

Finally I installed Geopsy 3.3 from the git repository with Qt 5.15.0.

Thank you

admin
Site Admin
Posts: 501
Joined: Mon Aug 13, 2007 11:48 am
Location: ISTerre
Contact:

Re: ERROR INSTALLATION IN UBUNTU 20.04

Post by admin »

Hi Nanda,

Good to read that you finally found a solution. Any particular error you fixed with Qt 5.15? I've never tried it, I'm still with Qt 5.14. If you still have the 3.4 folder available, I would be curious to get the full log (re-run make in it). The ending part you provided does not contain all the information needed to localize the error.

I'll check the former errors you got with 3.3.2. I think that a "make -i" would have provided a working package because the reported error is minor.

Best regards,

Marc

Post Reply