Geopsy 2.10.1 installation problem

Post in this forum any question related to the installation on any of the supported platforms (Linux, Mac OS X, Windows)
Post Reply
josh
Posts: 1
Joined: Thu Aug 06, 2020 2:14 pm

Geopsy 2.10.1 installation problem

Post by josh »

Hi Marc,

I am trying to install the geopsy version 2.10.1 in Ubuntu 18.04.5 LTS, but I'm getting errors. I first tried to use qt 5.9 but the Ascii error. I fixed that using answers from the forum, but got more and more errors. So I then tried to use qt 4.7 and got this error instead : basically it cannot find QGpCoreTools.h. I tried to create a soft-link, which did work for QGpCoreTools.h, but then I got a series of other files not found.



src/Settings.h:33:10: fatal error: QGpCoreTools.h: No such file or directory
#include <QGpCoreTools.h>
^~~~~~~~~~~~~~~~
compilation terminated.
In file included from src/Application.cpp:28:0:
src/Application.h:32:10: fatal error: QGpCoreTools.h: No such file or directory
#include <QGpCoreTools.h>
^~~~~~~~~~~~~~~~
compilation terminated.
Makefile.Release:739: recipe for target 'release/Attachments.o' failed
make[2]: *** [release/Attachments.o] Error 1
make[2]: *** Waiting for unfinished jobs....
Makefile.Release:731: recipe for target 'release/Application.o' failed
make[2]: *** [release/Application.o] Error 1
src/BugReport.cpp:30:10: fatal error: QGpCoreTools.h: No such file or directory
#include <QGpCoreTools.h>
^~~~~~~~~~~~~~~~
compilation terminated.
Makefile.Release:751: recipe for target 'release/BugReport.o' failed
make[2]: *** [release/BugReport.o] Error 1
make[2]: Leaving directory '/home/joshi/geopsypack-src-2.10.1/QGpGuiTools'
Makefile:34: recipe for target 'release' failed
make[1]: *** [release] Error 2
make[1]: Leaving directory '/home/joshi/geopsypack-src-2.10.1/QGpGuiTools'
Makefile:151: recipe for target 'sub-QGpGuiTools-make_default-ordered' failed
make: *** [sub-QGpGuiTools-make_default-ordered] Error 2


Any ideas of what can be done?

Regards,
Joshi

admin
Site Admin
Posts: 501
Joined: Mon Aug 13, 2007 11:48 am
Location: ISTerre
Contact:

Re: Geopsy 2.10.1 installation problem

Post by admin »

Hi,

This release is not supported any more. Even if you manage to solve the first problem, I'm unsure if you can get to the end without getting other errors. If you really need this old release, the easiest way is to test it under Windows (in a virtual machine). If I can re-install a Qt 4 on my machine, I'll try to do the compilation.

Best regards,

Marc

admin
Site Admin
Posts: 501
Joined: Mon Aug 13, 2007 11:48 am
Location: ISTerre
Contact:

Re: Geopsy 2.10.1 installation problem

Post by admin »

I managed to partially compile Qt 4.8.7 with gcc 6.3, except QtScript module due to errors in Javascript tools.

I started the compilation of 2.10.1 and ran into the same errors as reported.
There is a missing internal include path. You can fix this by running:

Code: Select all

./configure -I /tmp/geopsypack-src-2.10.1/include
Replace "/tmp/geopsypack-src-2.10.1" by the actual path where you are compiling.

Compile went fine until finding references to QtScript. Can you get to the end with the above work-around?

Post Reply