How to install Geopsy 3.2.0 - ANSWERS!

Post in this forum any question related to the installation on any of the supported platforms (Linux, Mac OS X, Windows)
Post Reply
Posts: 6
Joined: Wed Oct 02, 2019 9:04 pm

How to install Geopsy 3.2.0 - ANSWERS!

Post by EduardoPitta »

Hello everyone,
After a lot of struggle, I finally installed geopsy in my PC.
Here I will put instructions and solutions to problems so you all can use Geopsy faster than I did.

1. Qt Version
The ideal Qt version for that version of Geopsy is equal or above 5.7, however version 5.7 doesn't seem to work. The Qt version used in the installation tutorial was 5.11.
That way I had two solutions to try:

1-Install the latest Qt in Ubuntu from source
2-Install Debian 10 (Buster)

Why Debian 10? Because it comes with Qt 5.11 by default, so you don't have to risk messing with root and the like. If you want to try to install Qt 5.11 in Ubuntu, get in touch, I'm eager to learn how to do it.

2.Window Manager
After I installed geopsy successfully, the first thing I realized is that I couldn't see any kind of image it generates.
The solution is simple, use a Window Manager that supports Wayland.
I'm not really sure what it is, but here is the solution:

1- At the login screen, click at the cog icon.
2- Select Xfce, if avaliable, if not, install it through apt-get.
3- Log-in and have fun.

So far this is what I remember on how to install it, shoot your questions and I will try to answer.


Re: How to install Geopsy 3.2.0 - ANSWERS!

Post by tsonne »

There should be multiple ways to get various Qt versions installed. For example, I used Anaconda (or conda) to enable a virtual programming environment without requiring virtual operating systems. Updating it to the newest version gives Qt 5.12.5 at this point. My Ubuntu 16.04 had Qt 5.5.1, but using the conda environment all development files from conda are used instead of the base OS.

Had an issue with a missing library file in the conda path, all g++ compiled parts would not compile:

Code: Select all

make -j 8  # using 8 cores
...  # stuff happens until the error:
g++: error: /mnt/M2_1/prog/anaconda3/bin/../x86_64-conda_cos6-linux-gnu/sysroot/usr/lib64/ No such file or directory
I linked my OS to where the Geopsy configuration was expecting it and everything installed fine. It's a messy fix though, and not related to any Geopsy issues.

To link files as in the case of a missing library on the search path:

Code: Select all

ln -s /usr/lib/x86_64-linux-gnu/mesa/ /mnt/M2_1/prog/anaconda3/x86_64-conda_cos6-linux-gnu/sysroot/usr/lib64/
This assumes an existing in the system, but if that's not available, apparently installing something like libgl1-mesa-glx will create it. To find OS libraries like, this should work:

Code: Select all


Site Admin
Posts: 537
Joined: Mon Aug 13, 2007 11:48 am
Location: ISTerre

Re: How to install Geopsy 3.2.0 - ANSWERS!

Post by admin »

Thanks for your contributions.
With geopsy 3.2.*, if you try Qt>5.12.*, you will probably get into troubles. I've never try to compile with Qt 5.13
Recently, I was able to compile it with Qt 5.6 and gcc 4.4 (an old CentOS), with some fixes that will be available in 3.3.0. And apparently it worked without messing around with the system.

Posts: 2
Joined: Thu Nov 28, 2019 4:31 pm

Re: How to install Geopsy 3.2.0 - ANSWERS!

Post by alecomunian »

Hereinafter I will list the steps that I used to install version 3.2.2 on an Ubuntu 18.04 machine. Suggestions on the other posts were useful, but hereinafter I prefer to post the procedure I followed:

1) Install Qt.
Download the installer from ... (note that version 5.11 is not listed in the repository). Then the installation is time consuming but quite straightforward. (NOTE: In my case, I installed Qt in a directory called opt in my home folder)

2) Select the right qmake version:
The default version available from the Ubuntu repositories is related to Qt5.7. To override the default version, probably the easiest way is to add the directory pointing to the Qt5.11.3 binary file to your PATH. In my case, this is the line on my .bash_aliases file:

Code: Select all

export PATH=${HOME}/opt/Qt5.11.3/5.11.3/gcc_64/bin:${PATH}
Then restart your terminal. By defining the default qmake In this way, you should not mess up too much all the default Qt installation.
You can check if you are using the right version of qmake by typing qmake -v.

3) Compile geopsy
This should be quite easy by following the instruction provided in the file INSTALL.

I had some problems in displaying graphics, which were solved by deleting some configuration files/dirs from previous installations located in the .config directory. The files/dirs are geopsy.conf and geopsy. I also tried to activate/deactivate from the Ubuntu log-in screen the option Wayland, but that had no effect. Only deleting the two mentioned items solved.

Michael Ezersky
Posts: 2
Joined: Thu May 14, 2020 3:10 pm

Re: How to install Geopsy 3.2.0 - ANSWERS!

Post by Michael Ezersky »


Would you please help me download version Geopsy 3.2.0. I cannot install the win64 version to my computer. my e-mail

Thank you beforehand

Michael Ezersky

Post Reply